<!DOCTYPE html>

<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">

<head>

	<meta charset="UTF-8">

	<meta name="viewport" content="width=device-width, initial-scale=1">

	<link rel="profile" href="http://gmpg.org/xfn/11">

	<link rel="pingback" href="http://radioboracay.com/xmlrpc.php">

	<title>Davao Caticlan Boracay Direct Flights - FINALLY! &raquo; Radio Boracay</title>

<!-- This site is optimized with the Yoast SEO plugin v4.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="This is it! Davao Caticlan Boracay direct flights! Thanks to AirAsia &amp; the newly updated Caticlan airport for making this possible."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://radioboracay.com/travel/davao-caticlan-boracay-direct-flights/" />
<link rel="publisher" href="https://plus.google.com/+RadioboracayRB106"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Davao Caticlan Boracay Direct Flights - FINALLY! &raquo; Radio Boracay" />
<meta property="og:description" content="This is it! Davao Caticlan Boracay direct flights! Thanks to AirAsia &amp; the newly updated Caticlan airport for making this possible." />
<meta property="og:url" content="http://radioboracay.com/travel/davao-caticlan-boracay-direct-flights/" />
<meta property="og:site_name" content="Radio Boracay" />
<meta property="article:publisher" content="https://www.facebook.com/rb106boracay" />
<meta property="article:tag" content="Davao-Caticlan-Direct" />
<meta property="article:section" content="Travel" />
<meta property="article:published_time" content="2017-02-24T15:25:06+08:00" />
<meta property="article:modified_time" content="2017-02-24T17:14:58+08:00" />
<meta property="og:updated_time" content="2017-02-24T17:14:58+08:00" />
<meta property="fb:admins" content="1246710500" />
<meta property="og:image" content="http://radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg" />
<meta property="og:image:width" content="1188" />
<meta property="og:image:height" content="249" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="This is it! Davao Caticlan Boracay direct flights! Thanks to AirAsia &amp; the newly updated Caticlan airport for making this possible." />
<meta name="twitter:title" content="Davao Caticlan Boracay Direct Flights - FINALLY! &raquo; Radio Boracay" />
<meta name="twitter:site" content="@radioboracay" />
<meta name="twitter:image" content="https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?fit=1188%2C249" />
<meta name="twitter:creator" content="@radioboracay" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Radio Boracay &raquo; Feed" href="http://radioboracay.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Radio Boracay &raquo; Comments Feed" href="http://radioboracay.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Radio Boracay &raquo; Davao Caticlan Boracay Direct Flights &#8211; FINALLY! Comments Feed" href="http://radioboracay.com/travel/davao-caticlan-boracay-direct-flights/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/radioboracay.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=a3b1e8ac6c0ef2f0fd38349b4f14e336"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wpfront-scroll-top-css'  href='http://radioboracay.com/wp-content/plugins/wpfront-scroll-top/css/wpfront-scroll-top.min.css?ver=1.5' type='text/css' media='all' />
<link rel='stylesheet' id='lyrical-css'  href='http://radioboracay.com/wp-content/themes/lyrical/style.css?ver=1.0.0' type='text/css' media='all' />
<style id='lyrical-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wpcw-css'  href='http://radioboracay.com/wp-content/plugins/contact-widgets/assets/css/style.min.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=1.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='gem-base-css'  href='http://radioboracay.com/wp-content/plugins/godaddy-email-marketing-sign-up-forms/css/gem.min.css?ver=1.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='lyrical-fonts-css'  href='//fonts.googleapis.com/css?family=Playfair+Display%3A300%2C400%2C700%7CRaleway%3A300%2C400%2C700&#038;subset=latin&#038;ver=a3b1e8ac6c0ef2f0fd38349b4f14e336' type='text/css' media='all' />
<style id='lyrical-fonts-inline-css' type='text/css'>
.site-title {
	font-family: "Playfair Display", sans-serif;
}

.main-navigation ul li a,
.main-navigation ul li a:visited,
button,
a.button,
a.fl-button,
input[type="button"],
input[type="reset"],
input[type="submit"] {
	font-family: "Raleway", sans-serif;
}

h1,
h2,
h3,
h4,
h5,
h6,
label,
legend,
table th,
dl dt,
.entry-title,
.widget-title {
	font-family: "Raleway", sans-serif;
}

body,
p,
ol li,
ul li,
dl dd,
.fl-callout-text {
	font-family: "Raleway", sans-serif;
}

blockquote,
.entry-meta,
.entry-footer,
.comment-list li .comment-meta .says,
.comment-list li .comment-metadata,
.comment-reply-link,
#respond .logged-in-as {
	font-family: "Raleway", sans-serif;
}

</style>
<link rel='stylesheet' id='social-logos-css'  href='http://radioboracay.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://radioboracay.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.11 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-21320346-7', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('set', 'anonymizeIp', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('require', 'linkid', 'linkid.js');
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://radioboracay.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://radioboracay.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://radioboracay.com/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type="text/javascript" src="http://radioboracay.com/wp-content/plugins/wpfront-scroll-top/js/wpfront-scroll-top.min.js?ver=1.5" async="true"></script>
<!-- MonsterInsights JS Event Tracking -->
<script type="text/javascript" data-cfasync="false">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</script>
<!-- End MonsterInsights JS Event Tracking -->
<link rel='https://api.w.org/' href='http://radioboracay.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://radioboracay.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://radioboracay.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://radioboracay.com/?p=1516' />
<link rel="alternate" type="application/json+oembed" href="http://radioboracay.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fradioboracay.com%2Ftravel%2Fdavao-caticlan-boracay-direct-flights%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://radioboracay.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fradioboracay.com%2Ftravel%2Fdavao-caticlan-boracay-direct-flights%2F&#038;format=xml" />
<script type="text/javascript">var ajaxurl = "http://radioboracay.com/wp-admin/admin-ajax.php"</script>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<style type='text/css'>img#wpstats{display:none}</style><style type='text/css'>
.site-title a,
.site-title a:visited {
	color: ffffff;
}

</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<link rel="amphtml" href="http://radioboracay.com/travel/davao-caticlan-boracay-direct-flights/amp/" /><link rel="icon" href="https://i0.wp.com/radioboracay.com/wp-content/uploads/2016/11/cropped-FAVICON-Png.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/radioboracay.com/wp-content/uploads/2016/11/cropped-FAVICON-Png.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/radioboracay.com/wp-content/uploads/2016/11/cropped-FAVICON-Png.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/radioboracay.com/wp-content/uploads/2016/11/cropped-FAVICON-Png.png?fit=270%2C270" />
			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.
*/			</style>
		
</head>

<body class="post-template-default single single-post postid-1516 single-format-standard custom-background custom-header-image layout-two-column-default">

	
	<div id="page" class="hfeed site">

		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		
		<header id="masthead" class="site-header" role="banner">

			<div class="site-header-wrapper">

				
<div class="site-title-wrapper">

	
	<h1 class="site-title"><a href="http://radioboracay.com/" rel="home">Radio Boracay</a></h1>
	<div class="site-description">Boracay Travel Radio Philippines</div>
</div><!-- .site-title-wrapper -->

<div class="main-navigation-container">

	
<div class="menu-toggle" id="menu-toggle">
	<div></div>
	<div></div>
	<div></div>
</div><!-- #menu-toggle -->

	<nav id="site-navigation" class="main-navigation">

		<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li id="menu-item-1236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1236"><a href="http://radioboracay.com/">Home</a></li>
<li id="menu-item-333" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-333"><a href="http://radioboracay.com/boracay-radio/">Radio</a>
<a class="expand" href="#"></a>
<ul class="sub-menu">
	<li id="menu-item-1248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1248"><a href="http://radioboracay.com/tag/pt20-chart/">Top 20</a></li>
	<li id="menu-item-1177" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1177"><a href="http://radioboracay.com/boracay-radio/radio-boracay-projects/">Projects</a></li>
	<li id="menu-item-1148" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1148"><a href="http://radioboracay.com/marketing-advertising-services/">Services</a></li>
</ul>
</li>
<li id="menu-item-312" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-312"><a href="http://radioboracay.com/boracay-travel/">Boracay</a>
<a class="expand" href="#"></a>
<ul class="sub-menu">
	<li id="menu-item-741" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-741"><a href="http://radioboracay.com/boracay-travel/boracay-hotel/">Hotels</a>
	<a class="expand" href="#"></a>
	<ul class="sub-menu">
		<li id="menu-item-1155" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-1155"><a href="http://radioboracay.com/travel/boracay-hotels-beachfront-white-beach-top-10/">Top 10 Beachfront</a></li>
	</ul>
</li>
	<li id="menu-item-791" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-791"><a href="http://radioboracay.com/boracay-travel/boracay-flights/">Flights</a></li>
	<li id="menu-item-1050" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1050"><a href="http://radioboracay.com/boracay-travel/">Travel Tips</a></li>
</ul>
</li>
<li id="menu-item-776" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-776"><a href="http://radioboracay.com/blog/">Blog</a>
<a class="expand" href="#"></a>
<ul class="sub-menu">
	<li id="menu-item-982" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-982"><a href="http://radioboracay.com/category/music/">Music</a></li>
	<li id="menu-item-983" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-983"><a href="http://radioboracay.com/category/community/">Community</a></li>
	<li id="menu-item-1049" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1049"><a href="http://radioboracay.com/category/travel/">Travel News</a></li>
</ul>
</li>
<li id="menu-item-172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-172"><a href="http://radioboracay.com/boracay-radio/radio-boracay-stations/">About</a>
<a class="expand" href="#"></a>
<ul class="sub-menu">
	<li id="menu-item-1088" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1088"><a href="http://radioboracay.com/sitemap-radio-boracay-directory/">Sitemap</a></li>
	<li id="menu-item-1331" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1331"><a rel="nofollow" href="http://radioboracay.com/terms/">Terms</a></li>
</ul>
</li>
<li id="menu-item-171" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171"><a href="http://radioboracay.com/contact/">Contact</a></li>
</ul></div>
	</nav><!-- #site-navigation -->

	
</div>

<div class="hero">

	<div class="hero-inner">

		
<div class="page-title-container">

	<header class="page-header">

		
		<h1 class="page-title">BLOG &#8211; Radio Boracay Music &#038; Travel News</h1>

		
	</header><!-- .entry-header -->

</div><!-- .page-title-container -->

	</div>

</div>

			</div><!-- .site-header-wrapper -->

			
		</header><!-- #masthead -->

		
		<div id="content" class="site-content">

<div id="primary" class="content-area">

	<main id="main" class="site-main" role="main">

	
		
<article id="post-1516" class="post-1516 post type-post status-publish format-standard has-post-thumbnail hentry category-travel tag-davao-caticlan-direct">

	
<header class="entry-header">

	<div class="entry-header-row">

		<div class="entry-header-column">

			
			
				<h1 class="entry-title">Davao Caticlan Boracay Direct Flights &#8211; FINALLY!</h1>

			
			
		</div><!-- .entry-header-column -->

	</div><!-- .entry-header-row -->

</header><!-- .entry-header -->

	
<div class="entry-meta">

	
		<span class="posted-date">February 24, 2017</span>

	
	<span class="posted-author"><a href="http://radioboracay.com/author/boracayinsider/" title="Posts by boracayinsider" rel="author">boracayinsider</a></span>

	
		<span class="comments-number">

			<a href="http://radioboracay.com/travel/davao-caticlan-boracay-direct-flights/#respond" class="comments-link" >Leave a comment</a>
		</span>

	
</div><!-- .entry-meta -->

	
	
		
<div class="entry-content">

	<p>For the very first time, Davaoeños can now fly direct to Caticlan Boracay. Living on the island for almost ten years now, Davao Caticlan Boracay direct flights &#8211; definitely a long time coming. Not to mention summer is just around the corner.</p>
<h2>Davao Caticlan Boracay Direct Flights</h2>
<figure id="attachment_1517" style="width: 1188px" class="wp-caption aligncenter"><a href="https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg" target="_blank"><img src="https://i2.wp.com/radioboracay.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?resize=688%2C144" class="wp-image-1517 size-full" title="Davao Caticlan Boracay Direct Flights - FINALLY!" alt="Davao Caticlan Boracay Direct Flights from AirAsia" srcset="https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?w=1188 1188w, https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?resize=300%2C63 300w, https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?resize=768%2C161 768w, https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?resize=1024%2C215 1024w" sizes="(max-width: 688px) 100vw, 688px" data-recalc-dims="1"><noscript><img class="wp-image-1517 size-full" title="Davao Caticlan Boracay Direct Flights - FINALLY!" src="https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?resize=688%2C144" alt="Davao Caticlan Boracay Direct Flights from AirAsia" srcset="https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?w=1188 1188w, https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?resize=300%2C63 300w, https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?resize=768%2C161 768w, https://i0.wp.com/radioboracay.com/wp-content/uploads/2017/02/Davao-Caticlan-Boracay-Direct-Flights-AirAsia-February-2017.jpg?resize=1024%2C215 1024w" sizes="(max-width: 688px) 100vw, 688px" data-recalc-dims="1" /></noscript></a><figcaption class="wp-caption-text">AirAsia &#8211; first airline to offer Davao &#8211; Caticlan Boracay direct flights.</figcaption></figure>
<p>Thanks to AirAsia for being the first airline to offer this route. Albeit, Cebu Pacific did have <a href="https://boracayinsider.wordpress.com/2012/08/05/davao-to-boracay-kalibo-direct-flights/" target="_blank">Kalibo-Davao flights</a> back in 2012, they only offered the route for about a year. With the <a href="http://radioboracay.com/travel/caticlan-boracay-airport/" target="_blank">newly updated Caticlan Boracay airport</a>, Cebu Pacific and other domestic airlines would probably follow suit.</p>
<h2>Book Your Summer Vacation Now</h2>
<p>Now is the best time to book your flights to your summer destination. In light of these new routes, AirAsia is also offering promo airfares and direct flights from Davao to Puerto Princesa Palawan and vice versa &#8217;til <strong>26th February 2017</strong>. See promo airfares and flights from <a href="http://www.airasia.com/ph/en/home.page" target="_blank rel=">AirAsia</a>.</p>
<p><em>(Note: We are not an affiliate of AirAsia or any other airline. Hence, this is not a paid report.)</em></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://radioboracay.com/travel/davao-caticlan-boracay-direct-flights/" data-layout="button_count"></div></li><li class="share-google-plus-1"><div class="googleplus1_button"><div class="g-plus" data-action="share" data-annotation="bubble" data-href="http://radioboracay.com/travel/davao-caticlan-boracay-direct-flights/"></div></div></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>You might also like</em></h3>
</div>
</div><!-- .entry-content -->

	
	
<footer class="entry-footer">

	<div class="entry-footer-right">

		
	</div>

	
		
		
			<span class="cat-links">

				Posted in: <a href="http://radioboracay.com/category/travel/" rel="category tag">Travel</a>
			</span>

		
		
		
			<span class="tags-links">

				Filed under: <a href="http://radioboracay.com/tag/davao-caticlan-direct/" rel="tag">Davao-Caticlan-Direct</a>
			</span>

		
	
</footer><!-- .entry-footer -->

</article><!-- #post-## -->

		
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://radioboracay.com/music/philippines-top-20-songs-february-2017-pt20-chart/" rel="prev">&larr; Philippines Top 20 Songs February 2017 PT20 Chart</a></div></div>
	</nav>
		
			
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/travel/davao-caticlan-boracay-direct-flights/#respond" style="display:none;">Cancel reply</a></small></h3>
			<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=110491207&#038;postid=1516&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=gravatar_default&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.6&#038;sig=33e6516fc203ed7a607c0f65eedc60d8806b1368#parent=http%3A%2F%2Fradioboracay.com%2Ftravel%2Fdavao-caticlan-boracay-direct-flights%2F" allowtransparency="false" style="width:100%; height: 430px;border:0;" frameBorder="0" scrolling="no" name="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->

		
	
	</main><!-- #main -->

</div><!-- #primary -->




		</div><!-- #content -->

		
		<footer id="colophon" class="site-footer">

			<div class="site-footer-inner">

					<div class="footer-widget-area columns-3">

	
		<div class="footer-widget">

			<aside id="text-11" class="widget widget_text"><h4 class="widget-title">One Media Boracay Inc.</h4>			<div class="textwidget"><p>Radio Boracay Studios<br />
Boracay Bulabog Rd<br />
Malay Aklan Philippines<br />
5608</p>
<p>+63 (36) 288.6966</p>
</div>
		</aside><aside id="text-12" class="widget widget_text"><h4 class="widget-title">Disclosure</h4>			<div class="textwidget">Some pages on this site may contain affiliate links from companies we believe can help our users find what they are looking for. If a user decides to buy one of their products or services, we receive a commission to buy us coffee.</div>
		</aside>
		</div>

	
		<div class="footer-widget">

			<aside id="wpcw_social-6" class="widget wpcw-widgets wpcw-widget-social"><h4 class="widget-title">Follow us</h4><ul><li class="has-label"><a href="https://www.facebook.com/radioboracay" target="_blank" title="Visit Radio Boracay on Facebook"><span class="fa fa-2x fa-facebook-official"></span>Facebook</a></li></ul></aside><aside id="text-14" class="widget widget_text"><h4 class="widget-title">Terms</h4>			<div class="textwidget"><a href="/terms/">Terms & Conditions</a></div>
		</aside>
		</div>

	
		<div class="footer-widget">

			<aside id="gem-form-5" class="widget gem-form"><h4 class="widget-title">Join Our commUNITY</h4><p>Sign up to receive timely, useful information in your inbox like travel deals, music news, and more.</p>

			<div class="gem-form-wrapper" id="form-318965">
				<form action="https://gem.godaddy.com/signups/subscribe/318965" method="post" class="gem-form">

					
					
						<p>
		<label for="form_1_signup[email]">

			Email
							<span class="required">*</span>
			
		</label>
		<br/>

		<input type="text" name="signup[email]" id="form_1_signup[email]" class="gem-field gem-required" data-label="Email" />

		</p>

					
						<p></p>

					
					
					<p>
						<input type="hidden" name="form_id" value="318965" />
						<input type="submit" value="Subscribe" class="button gem-submit" />
						<span class="gem-spinner"></span>
					</p>

					
				</form>
			</div>

			</aside>
		</div>

	
	</div>
	
			</div><!-- .site-footer-inner -->

		</footer><!-- #colophon -->

		
<div class="site-info-wrapper">

	<div class="site-info">

		<div class="site-info-inner">

			
<div class="site-info-text">

	Copyright &copy; 2017 Radio Boracay &mdash; Lyrical WordPress theme by <a href="https://www.godaddy.com/" rel="author nofollow">GoDaddy</a>
</div>

		</div><!-- .site-info-inner -->

	</div><!-- .site-info -->

</div><!-- .site-info-wrapper -->

	</div><!-- #page -->

	


    <div id="wpfront-scroll-top-container"><img src="http://radioboracay.com/wp-content/plugins/wpfront-scroll-top/images/icons/59.png" alt="" /></div>
    <script type="text/javascript">function wpfront_scroll_top_init() {if(typeof wpfront_scroll_top == "function" && typeof jQuery !== "undefined") {wpfront_scroll_top({"scroll_offset":100,"button_width":0,"button_height":0,"button_opacity":0.8,"button_fade_duration":200,"scroll_duration":400,"location":1,"marginX":20,"marginY":20,"hide_iframe":false,"auto_hide":"on","auto_hide_after":2});} else {setTimeout(wpfront_scroll_top_init, 100);}}wpfront_scroll_top_init();</script><div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>
			function renderGooglePlus1() {
				if ( 'undefined' === typeof gapi ) {
					return;
				}

				jQuery( '.g-plus' ).each(function() {
					var $button = jQuery( this );

					if ( ! $button.data( 'gplus-rendered' ) ) {
						gapi.plusone.render( this, {
							href: $button.attr( 'data-href' ),
							size: $button.attr( 'data-size' ),
							annotation: $button.attr( 'data-annotation' )
						});

						$button.data( 'gplus-rendered', true );
					}
				});
			}

			(function() {
				var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
				po.src = 'https://apis.google.com/js/plusone.js';
				po.innerHTML = '{"parsetags": "explicit"}';
				po.onload = renderGooglePlus1;
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			})();

			jQuery( document.body ).on( 'post-load', renderGooglePlus1 );
			</script>
			<script type='text/javascript' src='http://radioboracay.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201708'></script>
<script type='text/javascript' src='http://radioboracay.com/wp-content/themes/primer/assets/js/navigation.min.js?ver=1.5.1'></script>
<script type='text/javascript' src='http://radioboracay.com/wp-content/themes/primer/assets/js/skip-link-focus-fix.min.js?ver=1.5.1'></script>
<script type='text/javascript' src='http://radioboracay.com/wp-includes/js/comment-reply.min.js?ver=a3b1e8ac6c0ef2f0fd38349b4f14e336'></script>
<script type='text/javascript' src='http://radioboracay.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='http://radioboracay.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var GEM = {"thankyou":"Thank you for signing up!","thankyou_suppressed":"Thank you for signing up! Please check your email to confirm your subscription.","oops":"Oops! There was a problem. Please try again.","email":"Please enter a valid email address.","required":"%s is a required field."};
/* ]]> */
</script>
<script type='text/javascript' src='http://radioboracay.com/wp-content/plugins/godaddy-email-marketing-sign-up-forms/js/gem.min.js?ver=1.2.0'></script>
<script type='text/javascript' src='http://radioboracay.com/wp-includes/js/wp-embed.min.js?ver=a3b1e8ac6c0ef2f0fd38349b4f14e336'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://radioboracay.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.6'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>

		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=110491207&postid=1516&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=33e6516fc203ed7a607c0f65eedc60d8806b1368#parent=http%3A%2F%2Fradioboracay.com%2Ftravel%2Fdavao-caticlan-boracay-direct-flights%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=110491207&postid=1516&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=33e6516fc203ed7a607c0f65eedc60d8806b1368#parent=http%3A%2F%2Fradioboracay.com%2Ftravel%2Fdavao-caticlan-boracay-direct-flights%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201708.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'110491207',post:'1516',tz:'8',srv:'radioboracay.com'} ]);
	_stq.push([ 'clickTrackerInit', '110491207', '1516' ]);
</script>

</body>

</html>
